[RÉSOLU] Incompatibilité version PHP

Pour les problèmes avec l'installation ou l'utilisation du script - About install and use problems.

Modérateurs : boulmontjj, Pierre G., Malabar, Otomatic

Règles du forum
Pensez à effectuer une recherche et à consulter la FAQ, la réponse à votre question a de grandes chances d'avoir déjà été donnée ;-).
Dans votre message, n'oubliez pas de mentionner l'URL vers votre livre d'or, cela nous permet de vous aider bien plus efficacement :super:.
corsesudlocation
Messages : 42
Inscription : Lun 23 Nov 2015, 12:00

Re: Incompatibilité version PHP

Messagepar corsesudlocation » Mer 24 Avr 2019, 12:28

Bonjour Malabar,
Je vous remercie pour la suggestion. J'ai fais du ménage, j'ai supprimé le dossier Guestbook qui ne me servait quand local.
Dans mes modifs précédentes j'avais oublié de modifier le fichier index.php situé dans agb_utf8 que j'avais téléchargé.
Désormais le livre d'or s'affiche mais il subsiste un message d'erreur sous l'entête, de plus il y a un problème d'affichage des caractères accentués
que je n'avais pas lorsque j'utilisais PHP 5.6.
En attendant une nouvelle suggestion, je vais passer le fichier Livredor.php en utf8 car j'ai découvert qu'il était en ANSI.
Alain

corsesudlocation
Messages : 42
Inscription : Lun 23 Nov 2015, 12:00

Re: Incompatibilité version PHP

Messagepar corsesudlocation » Mer 24 Avr 2019, 12:45

Rebonjour,
Désolé, j'ai oublié de vous mettre le lien vers le livre :
www.mas-senyarich.fr/Livredor.php
Alain

corsesudlocation
Messages : 42
Inscription : Lun 23 Nov 2015, 12:00

Re: Incompatibilité version PHP

Messagepar corsesudlocation » Mer 24 Avr 2019, 14:38

Bonjour,
J'ai modifié le chemin absolu que j'avais oublié dans le fichier Agb\index.php.
Le livre d'or s'affiche mais j'ai un warning juste sous l'entete. Pour le voir, voici le lien :
www.mas-senyarich.fr/Livredor.php
J'ai résolu le nouveau problème de caractères accentués en commentant //define('NAMES_UTF8',1);
Alain

corsesudlocation
Messages : 42
Inscription : Lun 23 Nov 2015, 12:00

Re: Incompatibilité version PHP

Messagepar corsesudlocation » Mer 24 Avr 2019, 15:41

Bonjour,
J'ai résolu le dernier problème : j'avais un Warning sous l'entete qui me signalait un problème à la ligne 198 du fichier agb_utf8\index.php.
J'ai supprimé la ligne : header("content_type:text/html; charset =$SCRIPT_ENCODAGE");
qui n'était pas dans mon ancien fichier.
Encore merci
Alain

Malabar
Admin
Admin
Messages : 4071
Inscription : Lun 07 Août 2006, 09:46
Localisation : Lorient
Contact :

Re: Incompatibilité version PHP

Messagepar Malabar » Mer 24 Avr 2019, 22:07

Super, félicitation pour votre persévérance !! ;)
Le mâle à barre (Maxime)


Revenir vers « Installation & utilisation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Bing [Bot] et 19 invités