Evolution du Livre d'or

Pour les problèmes avec l'installation ou l'utilisation du script - About install and use problems.

Modérateurs : boulmontjj, Pierre G., Malabar, Otomatic

Règles du forum
Pensez à effectuer une recherche et à consulter la FAQ, la réponse à votre question a de grandes chances d'avoir déjà été donnée ;-).
Dans votre message, n'oubliez pas de mentionner l'URL vers votre livre d'or, cela nous permet de vous aider bien plus efficacement :super:.
Schmol44
Messages : 92
Inscription : Mar 31 Juil 2007, 09:53
Localisation : Nantes
Contact :

Evolution du Livre d'or

Messagepar Schmol44 » Ven 25 Jan 2019, 10:25

Bonjour à tous,

Depuis des années, j'utilise ce Livre d'or en sous-domaine de mon site de type "[b]cms Guppy[/b]" qui a son propre livre d'or et le passer en "Php 7.2" et "https". J'aimerai le conserver pour ses nombreuses qualités.
Je constate que le livre d'or affiche ce genre d'erreurs, "Options g�n�rales", dû je pense au fait que le Livre d'or n'est pas en "utf8".
D'autres part, comment transformer l'url en "https"
En parcourant le Forum, je vois des solutions provisoires.
Envisagez vous une évolution de ce Livre d'or ?

D'avance merci pour votre réponse.
Dernière édition par Schmol44 le Lun 28 Jan 2019, 17:19, édité 1 fois.
Schmol44

Otomatic
Modérateur
Modérateur
Messages : 731
Inscription : Ven 11 Août 2006, 09:33
Localisation : Paris
Contact :

Re: Evolution du Livre d'or

Messagepar Otomatic » Ven 25 Jan 2019, 10:29

Bonjour,

Entre autres, lire viewtopic.php?f=2&p=17067#p17055
Ce n'est pas par ce que l'erreur se propage qu'elle devient vérité. Gandhi

Schmol44
Messages : 92
Inscription : Mar 31 Juil 2007, 09:53
Localisation : Nantes
Contact :

Re: Evolution du Livre d'or

Messagepar Schmol44 » Ven 25 Jan 2019, 10:56

Bonjour Otomatic,

Oui, j'ai vu, mais il y a du boulot, d'autant que sur mon site j'utilise d'autres Scripts et que je découvre le problème.
En tout cas, merci pour cette réponse rapide.
Je pense que je vais pouvoir m'en sortir, mais je ne suis pas sûr que se sera le cas de certains qui utilisent où voudraient utiliser ce magnifique Livre d'or, en créant un nouveau site en https, ce qui aujourd'hui est basique.
J'ai réalisé mon site en 2000 et depuis, je me suis "payé" beaucoup de modifs pour qu'aujourd'hui, il soit encore dans le coup.

Déjà, pour passer en "PHP 7.2, et obtenir le certificat pour "https", j'ai du modifier "mon pack" chez mon hébergeur, celui-ci étant "trop ancien" (comme moi, sûrement) et bien sûr, modifier mon abonnement. ;-)
Schmol44

Schmol44
Messages : 92
Inscription : Mar 31 Juil 2007, 09:53
Localisation : Nantes
Contact :

Re: Evolution du Livre d'or

Messagepar Schmol44 » Ven 25 Jan 2019, 18:51

Bonsoir Otomatic

J'ai fait la modif en local sous wamp. (php v5.6.31), ça fonctionne. Par contre ça ne fonctionne pas sur mon site en ligne, j'ai une page blanche comme avec xampp, également avec php 7.3.

En ligne, mon site principal est en php 7.2.3 mais n'a pas encore évolué en "https" (j'ai beaucoup de modifs à faire) "agb" est dans une "iframe".
La base de "agb"est en php 5.6 et évoluera plus tard en php 7.0, 7.1 ou 7.2, pour l'instant, l'urgence est "utf8".
En local, il n'est pas dans une "iframe" de mon site.

J'ai essayé en ligne, agb avec php 7.0, 7.1 et 7.2, ça ne fonctionne pas.
Quand j'ouvre mon livre d'or, j'obtiens le message suivant : "La version des fichiers est différente de la version de la base de données. Veuillez mettre à jour."
Je pense que cela est dû à la non modification de ma base "sql" en "sqli", d'après ce que j'ai lu sur le forum.
Je suis donc revenu à php 5.6
Mais j'ai toujours ce message,(alors qu'en local, ça fonctionne) Faut-il revenir à la version "agb v5.04" ? et passer seulement en "utf8" ?

D'avance un grand Merci à toi, pour tous les tutos en ligne et pour tes réponses.
Je précise que pour l'instant, je peux rester en php 5.6, j'évoluerais plus tard en 7.2 ça n'est pas urgent.
Schmol44

Schmol44
Messages : 92
Inscription : Mar 31 Juil 2007, 09:53
Localisation : Nantes
Contact :

Re: Evolution du Livre d'or

Messagepar Schmol44 » Lun 28 Jan 2019, 19:28

Bonsoir,
Bon, j'avance, sous "xampp" avec "php" 7.3, ça fonctionne en local.
Je pense qu'en ligne, ma base ne s'est pas mise à jour, je viens d'ouvrir un ticket chez mon hébergeur.
(Je viens de changer mon contrat chez eux, car avec l'ancien, je ne pouvais pas avoir au-dessus du "php5.6" et je ne pouvais pas bénéficier du protocole "https").
Affaire à suivre...
Schmol44

Otomatic
Modérateur
Modérateur
Messages : 731
Inscription : Ven 11 Août 2006, 09:33
Localisation : Paris
Contact :

Re: Evolution du Livre d'or

Messagepar Otomatic » Mar 29 Jan 2019, 10:37

Bonjour,

Quand j'ouvre mon livre d'or, j'obtiens le message suivant : "La version des fichiers est différente de la version de la base de données. Veuillez mettre à jour." Je pense que cela est dû à la non modification de ma base "sql" en "sqli", d'après ce que j'ai lu sur le forum.

Que nenni ! Le passage mysql -> mysqli est effectué par le code du Livre d'Or en version 5.0.6 par un simple changement de la class PHP utilisée.

Dans les différents messages dont j'ai mis les liens, par exemple celui-ci viewtopic.php?f=1&t=3272&p=16871&hilit=agb_utf8.zip#p16871 Il est noté que le numéro de version 5.0.6 doit être modifié manuellement directement dans la base de données.

C'est un fait de notre époque, la lecture des modes d'emploi ou des explications passe souvent à l'as ou est effectuée en diagonale, en plus dans le sens de l'épaisseur des pages.
Ce n'est pas par ce que l'erreur se propage qu'elle devient vérité. Gandhi

Schmol44
Messages : 92
Inscription : Mar 31 Juil 2007, 09:53
Localisation : Nantes
Contact :

Re: Evolution du Livre d'or

Messagepar Schmol44 » Mar 29 Jan 2019, 13:21

Bonjour Otomatic,

Oui, j'ai écrit une "conceté" comme disait un célèbre "MVP".
Le pire c'est que j'ai bien fait la modif et que j'ai lu et relu le lien que tu cites, c'est d'ailleurs pour ça que ça fonctionne en local sous "xampp" en php7.3.
J'ai également modifié la version 5.04 en 5.06 et je confirme que c'est bon quand j'interroge la version en admin.
Donc en local : :super:

Mon problème est en ligne, tout simplement parce que je n'arrive pas à importer la nouvelle base. (Bien sûr, je l'ai mise à jour de php5.6 à php 7.0)
J'ai une erreur qui me dit que la basse existe déjà.
J'hésite à supprimer l'ancienne avant de faire l'import.

Je viens d'ouvrir un ticket chez l'hébergeur.
Schmol44

Otomatic
Modérateur
Modérateur
Messages : 731
Inscription : Ven 11 Août 2006, 09:33
Localisation : Paris
Contact :

Re: Evolution du Livre d'or

Messagepar Otomatic » Mar 29 Jan 2019, 14:11

Bonjour,
Mon problème est en ligne, tout simplement parce que je n'arrive pas à importer la nouvelle base. (Bien sûr, je l'ai mise à jour de php5.6 à php 7.0)

A priori, il n'y a pas besoin d'importer la base. Il suffit simplement avec le PhpMyAdmin de l'hébergeur (Ou ce qui en tient lieu) d'aller modifier la base hébergée et la table et le champ idoine : table alex_livre_config pour mettre 5.0.6 pour le champ db_version.

“conceté”, c'est ©JCB un de mes vieux copains, bien trop tôt disparu.
Ce n'est pas par ce que l'erreur se propage qu'elle devient vérité. Gandhi

Schmol44
Messages : 92
Inscription : Mar 31 Juil 2007, 09:53
Localisation : Nantes
Contact :

Re: Evolution du Livre d'or

Messagepar Schmol44 » Mar 29 Jan 2019, 16:17

re Bonjour Otomatic,

Mais oui, mais c'est bien sûr.
J'étais justement en train de lire les données de cette table chez mon hébergeur et je me suis dit et si je modifiais ça ?
ça pourrait marcher.

Avant de le faire, j'ai consulté mes mails et je viens de lire ta réponse,
BINGO, ça fonctionne. :super: :super: :super:
Schmol44


Revenir vers « Installation & utilisation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Aucun utilisateur inscrit et 12 invités