Problème à la suite à un changement d'hébergeur

Pour les problèmes avec l'installation ou l'utilisation du script - About install and use problems.

Modérateurs : boulmontjj, Pierre G., Malabar, Otomatic

Règles du forum
Pensez à effectuer une recherche et à consulter la FAQ, la réponse à votre question a de grandes chances d'avoir déjà été donnée ;-).
Dans votre message, n'oubliez pas de mentionner l'URL vers votre livre d'or, cela nous permet de vous aider bien plus efficacement :super:.
Loubas
Messages : 6
Inscription : Jeu 06 Nov 2014, 02:44

Problème à la suite à un changement d'hébergeur

Messagepar Loubas » Sam 09 Juin 2018, 19:29

Bonjour, je viens de changer d'hébergeur Web, lorsque j'ai transféré mes fichiers locaux (dont celui relié à mon livre d'or) sur le nouveau serveur, le lien ne fonctionnait plus. J'ai donc téléchargé tous les fichiers de mon ancien hébergeur (au cas où ceux de mes fichiers locaux auraient été le problème) et téléchargé à nouveau les fichiers originaux de mon ancien hébergeur, mais cela ne fonctionne toujours pas. J'ai même essayé d'aller directement dans l'interface utilisateur (www.louisbastien.com/livredor/admin/index.php), mais la page n'apparaît plus. C'est dommage, car j’avais plusieurs commentaires, dont ceux de personnes qui sont décédés. J'aimerais savoir s'il y a possibilité de transformer ou réparer le lien. Pour l'instant, mon nouvel hébergeur n'est pas accessible, car il est en train de faire des changements à mon forfait. :/ Merci beaucoup !

Malabar
Admin
Admin
Messages : 4060
Inscription : Lun 07 Août 2006, 09:46
Localisation : Lorient
Contact :

Re: Problème à la suite à un changement d'hébergeur

Messagepar Malabar » Dim 10 Juin 2018, 10:48

Bonjour,

Vous avez plusieurs soucis.
Pour votre erreur (ici erreur 404, erreur bien connue), cela signifie que la page n'existe pas. Soit vous n'avez pas mis les fichiers au bon endroit chez votre hébergeur, soit vous n'avez pas mis les droits nécessaires pour pouvoir afficher la page. Seul votre hébergeur peut vous aider.

Ensuite vous allez être confronté à un autre problème. Les messages ne sont pas stockés dans des fichiers mais dans la base de données MySQL. Pour transférer votre livre, vous devez récupérer les fichiers mais également faire un export de la base de données.

Dernier point : vous devrez modifier un fichier de configuration pour indiquer les nouvelles informations de connexion à la base de données. Votre hébergeur doit vous proposer la création de bases de données MySQL. Une fois votre nouvelle base créée, vous aurez des identifiants, un nom de serveur et un nom de base de données.
Ce sont ces informations que vous devrez indiquer (en remplacement des informations de votre ancien hébergeur).
Le fichier à modifier est config/config_base.php

Essayez de résoudre votre problème d'erreur 404 et ensuite revenez nous voir :)
Le mâle à barre (Maxime)

Loubas
Messages : 6
Inscription : Jeu 06 Nov 2014, 02:44

Re: Problème à la suite à un changement d'hébergeur

Messagepar Loubas » Dim 10 Juin 2018, 20:25

Bonjour Malabar,

Merci beaucoup pour votre aide !

Le problème de l'erreur 404 est réglé, mon site Web s'affiche maintenant correctement, cela était dû à un problème de transfert de nom de domaine relié à mon ancien hébergeur.

J'ai fait un téléchargement complet de tout ce qui était sur mon ancien serveur, et j'ai trouvé (comme vous me l'aviez expliqué) dans le dossier "homedir/public_html/livredor/config", un dossier nommé "config_base.php". J'ai affiché son contenu, et (toujours comme vous me l’aviez expliqué) il y avait bel et bien mon nom d'utilisateur et mon mot de passe associés à mon ancien hébergeur.

Je vais communiquer avec mon nouvel hébergeur en début de semaine, pour lui demander (toujours comme vous me l’aviez expliqué) la création de bases de données MySQL (même si je ne sais pas vraiment de quoi il s'agit 8/ ).

Merci infiniment pour votre aide et vos précieux conseils ! :super:

Loubas
Messages : 6
Inscription : Jeu 06 Nov 2014, 02:44

Re: Problème à la suite à un changement d'hébergeur

Messagepar Loubas » Dim 17 Juin 2018, 19:23

Rebonjour Malabar,

J'ai finalement réussi à faire transférer ma base de données MySQL sur mon nouvel hébergeur, j'ai aussi modifié le dossier "config/config_base.php" de la racine de mon site (http://www.louisbastien.com/livredor/index.php, ainsi que celui trouvé dans "public_html...au cas), en y inscrivant les nouvelles informations fournies par un technicien de mon nouvel hébergeur. Mais lorsque je clique sur le lien de mon site menant vers le livre d'or, j'arrive toujours à un écran blanc ? 8|

Alors, j'aimerais savoir s’il y a quelque chose que je n'ai pas fait de la bonne façon ?

Merci beaucoup !

Otomatic
Modérateur
Modérateur
Messages : 646
Inscription : Ven 11 Août 2006, 09:33
Localisation : Paris
Contact :

Re: Problème à la suite à un changement d'hébergeur

Messagepar Otomatic » Lun 18 Juin 2018, 14:54

Bonjour,

Code : Tout sélectionner

Content-Type: text/html; charset=UTF-8
Date: Mon, 18 Jun 2018 12:51:03 GMT
Server: Apache
500 Internal Server Error

Erreur 500 : à 99% problème de connexion à MySQL. Le 1% restant pouvant être dû à une erreur dans un fichier .htaccess.

A priori, les paramètres de connexion MySQL dans config_base.php sont erronés.
Ce n'est pas par ce que l'erreur se propage qu'elle devient vérité. Gandhi

Loubas
Messages : 6
Inscription : Jeu 06 Nov 2014, 02:44

Re: Problème à la suite à un changement d'hébergeur

Messagepar Loubas » Jeu 21 Juin 2018, 15:57

Bonjour Otomatic,

Merci pour ta réponse, je vais "essayer" (car j'y arrive rarement... et je viens d'acheter un forfait pour 5 ans 8/ ) de parler avec un technicien de mon nouvel hébergeur, pour voir si les coordonnées qu'il m'a envoyées par courriel sont valides.

Loubas
Messages : 6
Inscription : Jeu 06 Nov 2014, 02:44

Re: Problème à la suite à un changement d'hébergeur

Messagepar Loubas » Jeu 21 Juin 2018, 19:47

Rebonjour Otomatic,

J'ai finalement réussi à parler avec un technicien du service à la clientèle de mon nouvel hébergeur, il a créé un fichier test dans ma base de données, et m'a donné le lien pour voir si les infos reliées à mon fichier "config/config_base.php" étaient correctes. Lorsque j’ai utilisé son lien (http://louisbastien.com/testdb.php), je voyais apparaître ce qu'il m'avait dit (Connected successfully).

J'ai affiché ce qui est écrit dans mon fichier (http://www.louisbastien.com/public_html ... /index.php) local que j’ai transféré sur le distant, et j'ai joint un JPG du texte.

Je ne sais plus trop quoi faire pour retrouver mon livre d'or ? 8|

J'ai aussi affiché ce qui était écrit dans le fichier ".htaccess", et je n'ai rien vu 8/

Merci

CapturFiles_10.jpg
Vous ne pouvez pas consulter les fichiers insérés à ce message.


Revenir vers « Installation & utilisation »

Qui est en ligne ?

Utilisateurs parcourant ce forum : Bing [Bot] et 25 invités